Home Vulnerability Critical Flaw Uncovered in WordPress Backup Plugin Used by Over 3 Million Sites

Critical Flaw Uncovered in WordPress Backup Plugin Used by Over 3 Million Sites

by
WordPress Backup Plugin

Patches have been issued to contain a “severe” security vulnerability in UpdraftPlus, a WordPress plugin with over three million installations, that can be weaponized to download the site’s private data using an account on the vulnerable sites.

“All versions of UpdraftPlus from March 2019 onwards have contained a vulnerability caused by a missing permissions-level check, allowing untrusted users access to backups,” the maintainers of the plugin said in an advisory published this week.

Automatic GitHub Backups

Security researcher Marc-Alexandre Montpas of Automattic has been credited with discovering and reporting the vulnerability on February 14 that’s been assigned the identifier CVE-2022-0633 (CVSS score: 8.5). The issue impacts UpdraftPlus versions from 1.16.7 to 1.22.2.

UpdraftPlus is a backup and restoration solution that’s capable of performing full, manual, or scheduled backups of WordPress files, databases, plugins and themes, which can then be reinstated via the WordPress admin dashboard.

A consequence of this defect is that it allows any logged-in user on a WordPress installation with UpdraftPlus installed to exercise the privilege of downloading an existing backup – permissions which should have been reserved for administrative users only.

Prevent Data Breaches

Beyond leaking passwords and other confidential data, it could also “in some cases site takeover if the attacker is able to obtain database credentials from a configuration file and successfully access the site database,” WordPress security company Wordfence said.

Users of the UpdraftPlus plugin are recommended to update to version 1.22.3 (or 2.22.3 for the Premium version) to mitigate any potential exploitation. The latest version available as of February 17 is 1.22.4, which addresses bugs related to printing auto-backup options on PHP 8.



Source link

Related Articles

Translate »